CVE-2021-4428 Statement

on Friday, 14 January 2022. Posted in News Blog, Frontpage News

HighTec IDE 2.x/3.x and Apache Log4j CVE-2021-44228

A vulnerability CVE-2021-44228 affecting Apache Log4j was discovered.

HighTec development team performed an investigation to assess the impact of the reported vulnerability CVE-2021-44228 on HighTec Integrated Development Environment (IDE) version 2.x and 3.x. Our conclusion is the HighTec IDE, all versions 2.x and 3.x, are NOT IMPACTED by this vulnerability. The vulnerability was introduced in the Log4j 2.x, which our IDE in question does not use. We may take further steps should new development concerning this vulnerability happen. As a general precaution, we strongly encourage users to use the latest updated IDE (download links below) and not install/use any 3rd party plugins/extensions.

News